Infiniti QX30 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I've read this on a couple of forums and was wondering if there has been a fix. It doesn't happen every time, but it's gotten more frequent recently. I have a 2017 QX30 and sometimes when I put the car in reverse, the screen goes black and stays black until I restart the car. It's not only frustrating but dangerous as the QX30 has very limited field of view.

Chris
 

·
Registered
Joined
·
29 Posts
ugh, had this happened for the first time after 2 months of ownership (got one used at 25k)

i'll keep you guys updated, will take car to dealership in the near future for this and coolant message on cold start.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Please do! I just got the coolant message, too!
Chris

ugh, had this happened for the first time after 2 months of ownership (got one used at 25k)

i'll keep you guys updated, will take car to dealership in the near future for this and coolant message on cold start.
 

·
Registered
Joined
·
3 Posts
Same.. I took it to the dealership (Infiniti of Coral Gables in Miami) and was basically told it's a known issue and there is no fix as of now. They said they would contact me if/when they found a solution. Not very encouraging.
 

·
Super Moderator
Joined
·
404 Posts
Infiniti has known about this for at least 2 years. I don’t think it’ll ever be fixed.
 

·
Registered
Joined
·
6 Posts
I have the same issue. I can't make it happen on command but I took a video the last time to show the dealer the next time I bring it in for service. It's happened to me 3 times in the last 6 months. 2017 w/nav.
 

·
Registered
Joined
·
31 Posts
I’ve had the same screen blackout problem a few times on my 2017 QX30. Also had a different, stranger screen/camera issue happen. The backup camera came on when put in reverse, but STAYED ON when I put car in drive. Very strange seeing live feed of what’s behind you as you go forward!
Anyone else experience this?
 
1 - 7 of 7 Posts
Top