Infiniti QX30 Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
First off...does the 2017 models have the REPLACE AUX BATTERY LIGHT? I still have not seen it in my car....but I did get the orange check engine light today.

My car was doing the radio popping off when the car restarts at the light thing but recently it graduated to not cranking back at all at the light and the red font warning saying not to shift and go to dealer yadda yadda. So i have been driving with the @A button off.

But this morning was a rare moment with no traffic in LA so i decided to drive with the @A on. Now at the first light it turned off like normal and wouldn't turn on same issue.
Now at the next light it turned off but i accidently released the brake almost instantly and it cranked back up!!! But then the check engine light came on. Then next light same thing...car would not crank back on, red message, re start car. Check engine still on.

Do you guys think this is 100% the AUX BATTERY? Only reason I have concerns it might be something else is no AUX battery light coming on and how it cranked back up when it was off for just a second today. Please help asap. I told my dealer to order one for me...only costs like 260 plus 15% off. Thanks in advance.
 

· Registered
Joined
·
2 Posts
First off...does the 2017 models have the REPLACE AUX BATTERY LIGHT? I still have not seen it in my car....but I did get the orange check engine light today. My car was doing the radio popping off when the car restarts at the light thing but recently it graduated to not cranking back at all at the light and the red font warning saying not to shift and go to dealer yadda yadda. So i have been driving with the @A button off. But this morning was a rare moment with no traffic in LA so i decided to drive with the @A on. Now at the first light it turned off like normal and wouldn't turn on same issue. Now at the next light it turned off but i accidently released the brake almost instantly and it cranked back up!!! But then the check engine light came on. Then next light same thing...car would not crank back on, red message, re start car. Check engine still on. Do you guys think this is 100% the AUX BATTERY? Only reason I have concerns it might be something else is no AUX battery light coming on and how it cranked back up when it was off for just a second today. Please help asap. I told my dealer to order one for me...only costs like 260 plus 15% off. Thanks in advance.
Replace the aux battery. It will solve all these issues
 

· Registered
Joined
·
77 Posts
Discussion Starter · #4 ·
I kinda had a feeling the aux battery was fine and I was right. I still haven't got the aux battery malfunction light like the others They tested it multiple times and it kept testing at 940....the dealership didn't have time to drive it and do a whole electric diagnostic because I wanted tires n alignment done first so I will have to come back. Really doesn't bother me...just gotta remember to turn the A button off. Now I'm really wondering what it could be!!!!???!!!
 
1 - 4 of 4 Posts
Top