Infiniti QX30 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello All, this is a first for me. I have read the many posts and mine seems to contain a bit of everything. Started with a faulty usb port and fuse. Then we had the Stop the car and have it towed to nearest dealership warning on the flat screen, with the accompanying immediate email, warning that warrantee could be voided if you continue driving. No engine light on cluster though. It was attributed to upcoming airbag recall. A couple of weeks later, rear passenger window would go down when cornering or braking. Changed switches and rebooted system. Cameras started to work in drive instead of reverse. Then had second "pull over immediat...." warning and email. Kept car for a week said it was good now. Third "pull over immed..." scanned car , now blamed on faulty sensor in windsheild washer container. Awaiting delivery of this part and 4th time for the flashing red warning on flat screen and email. Realized that during this time i have run out of gas 2x, been blaming myself for getting old, but have never run out of gas before , EVER. Ready to blow, just found this forum so i guess i need to start paper trail with Infiniti Canada. It's is a 2017 qx30s.
 

·
Registered
Joined
·
62 Posts
I have never had any of these issues and I am coming up on a year of having my Qx30. It sounds like a definite example of a Lemon Law candidate. Do you have that in Canada? Hopefully, you took pictures of the screen and everything when it happened. If that were my car, I would fight hard to get a new one and let them deal with that instead of you being hassled to bring it in repeatedly. Good luck and post an update.
 

·
Registered
Joined
·
62 Posts
Hello All, this is a first for me. I have read the many posts and mine seems to contain a bit of everything. Started with a faulty usb port and fuse. Then we had the Stop the car and have it towed to nearest dealership warning on the flat screen, with the accompanying immediate email, warning that warrantee could be voided if you continue driving. No engine light on cluster though. It was attributed to upcoming airbag recall. A couple of weeks later, rear passenger window would go down when cornering or braking. Changed switches and rebooted system. Cameras started to work in drive instead of reverse. Then had second "pull over immediat...." warning and email. Kept car for a week said it was good now. Third "pull over immed..." scanned car , now blamed on faulty sensor in windsheild washer container. Awaiting delivery of this part and 4th time for the flashing red warning on flat screen and email. Realized that during this time i have run out of gas 2x, been blaming myself for getting old, but have never run out of gas before , EVER. Ready to blow, just found this forum so i guess i need to start paper trail with Infiniti Canada. It's is a 2017 qx30s.
Hey Jeffj did you ever got your car fixed? what was the problem?
 

·
Registered
Joined
·
31 Posts
Check your wiring harness inside the top of your hatch. Mine is crushed on the left side. Infiniti won't replace since it's an $11,000 repair. Regional manager told me everything electrical runs through that harness and the wiring is getting pinched every time the hatch is opened and closed. She also said they won't do anything since I haven't had any problems "yet" with the electrical system. She also said that even if/when they replace it, it will happen again. If it's crushed once, it's going to get crushed again.

She also said while my case has been documented she can't guarantee that if these problems don't occur until after the warranty expires, that Infiniti will be willing to assist me.


I was told the only way something will be done is if enough people have this problem and complain to consumer affairs. IMHO it is a design flaw that Infiniti won't own up to.
 

·
Registered
Joined
·
2 Posts
Interested in how others have been dealt with with power / control issues

I had owned my qx30 just over 2 weeks when I had a message come up that the 4wd system was unavailable and my local dealer has had the car in for repair for over 2 weeks now apparently the 4wd system has no power getting to it but they have referred the diagnostics back to infiniti hq.

Thus far I have found dealing with Infiniti easy and using their breakdown service was a piece of cake they have even provided me with a hire car while mine is in for repair.
 

·
Registered
Joined
·
123 Posts
Seems like these "weird" electrical/computer/camera/sensor issues usually end up requiring Infiniti corporate to investigate and resolve. Mine were, among others here on this forum. Good luck and report back and let us know how things turn out.
 

·
Registered
Joined
·
2 Posts
Well an update I have the car back and Infiniti blamed a dashcam that was fitted. Not convinced the camera was installed professionally so the fitter is going to speak directly to the garage that had the car in for repair. Strange they handed it back to me without any charge even thought they said the problem was due to 3rd party.
 

·
Registered
Joined
·
62 Posts
Seems like these "weird" electrical/computer/camera/sensor issues usually end up requiring Infiniti corporate to investigate and resolve. Mine were, among others here on this forum. Good luck and report back and let us know how things turn out.
Mine has had the backup cam stay on while I was driving forward (this has happened twice). I made a video on my phone and took it to the dealer after the second time. Of course, they couldn't get it to do it, but at least I had the video.

They also said it was something they called corporate about and they were told it was a software issue. That was around mid November and now it hasn't happened since.
 

·
Registered
Joined
·
36 Posts
Got in the car Saturday, had “check brake wear” and “abs inoperable” warnings. Also CEL on. Power steering doesn’t work. Took it in this morning was told it was a faulty sensor. We’ll see. BTW - 2018 QX30S, bought in May, 5500 miles.
 

·
Registered
Joined
·
36 Posts
Service rep texted me this morning telling me it was “rodent damage” to the wiring harness, not covered by warranty and I will be responsible to pay for the repairs. I’m going in this afternoon to discuss. I regret buying this vehicle.
 

·
Registered
Joined
·
184 Posts
Can they prove that it is rodents vs some other type of failure? Do you live in an area where that could be possible?
If it was rodent damage, would they have not been able to chew up a different car?

Sorry about what sounds like incredibly bad luck... What about insurance? I would give them a call...


Service rep texted me this morning telling me it was “rodent damage” to the wiring harness, not covered by warranty and I will be responsible to pay for the repairs. I’m going in this afternoon to discuss. I regret buying this vehicle.
 

·
Super Moderator
Joined
·
403 Posts
Service rep texted me this morning telling me it was “rodent damage” to the wiring harness, not covered by warranty and I will be responsible to pay for the repairs. I’m going in this afternoon to discuss. I regret buying this vehicle.
Why do you regret buying this vehicle? Rodent damage would happen to any vehicle.

Can they prove that it is rodents vs some other type of failure? Do you live in an area where that could be possible?
If it was rodent damage, would they have not been able to chew up a different car?

Sorry about what sounds like incredibly bad luck... What about insurance? I would give them a call...
Rodent damage should be easy to prove... They should be able to show him the chewed harness.

And yes, XIS may be correct to suggest contacting insurance... Depending on the cost of the repair. Obviously if it's less than, or even slightly over your deductible then I'd pay out of pocket. But if it's considerably more than your deductible, then it may be worth invoking your comprehensive coverage.
 
  • Like
Reactions: Rapidfirerob4

·
Registered
Joined
·
36 Posts
They showed me the damage and it was pretty obvious that the wires were chewed. $1300 to fix. I filed a claim. My statement of regret was based on seeing so many reports in this forum of electrical issues similar to mine that Infiniti couldn’t diagnose and seemed to look for excuses.
 

·
Registered
Joined
·
17 Posts
You have to understand that the QX30 is not an Infiniti...it is a Mercedes Benz with an Infiniti body. Everything about this car mechanically and electrically is MB except the infotainment.

Infiniti doesn't know how to fix them without assistance because they have never had a vehicle that was a joint venture with another automaker. From everything I have read, these and the MB GLA-250 are pretty reliable cars.

My QX30 has 42K miles (I bought it at 36K). The service history only has the coolant level sensor and a rear door seal as repairs done to it.
 

·
Registered
Joined
·
62 Posts
They said they should have it with my next service. It has only happened one more time, where it stayed on until I shut the car off. Occasionally, the backup camera will stay on for maybe 15 seconds after I start driving forward.
 

·
Registered
Joined
·
31 Posts
You have to understand that the QX30 is not an Infiniti...it is a Mercedes Benz with an Infiniti body. Everything about this car mechanically and electrically is MB except the infotainment.

Infiniti doesn't know how to fix them without assistance because they have never had a vehicle that was a joint venture with another automaker. From everything I have read, these and the MB GLA-250 are pretty reliable cars.

My QX30 has 42K miles (I bought it at 36K). The service history only has the coolant level sensor and a rear door seal as repairs done to it.
Has anyone considered asking their local Mercedes dealership if they would be willing to service the QX30 since it is definitely a Mercedes engine/interior covered by an Infiniti body?
 
1 - 17 of 17 Posts
Top