Infiniti QX30 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
It has happened to me several times. I am hearing music, then suddenly it stops and starts playing thorugh the phone speaker with a screen message "check bluetooth connection". Sometimes it just reconnects by itself, another times I have to reset the radio (7 secons power off buttopn hold) and then it just reconnects. Last week in a two hour trip it dosconnected more than ten times!!! Can be really annoying when trying to hear music from Pandora or spotify (since we dont have android or iphone carplay). Anyone else with this issue?
 

·
Super Moderator
Joined
·
403 Posts
My wife and I have not had that issue. We both have iPhones.

Do you have an iPhone or Android?
Do you have any other phones you could test in your car?
Do you have any other cars you could test your phone in?
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
My wife and I have not had that issue. We both have iPhones.

Do you have an iPhone or Android?
Do you have any other phones you could test in your car?
Do you have any other cars you could test your phone in?
Hi! I have an Android, Motorola Z2 Force. My wife has an S8. Happens more in my phone than hers, cause I drive the QX a lot more. But has happened with both phones. We also have a 2012 Scion iQ with no issues neither my phone nor hers. We also noted in our QX that there's a delay in the bluetooth connection. If we are for example watching a bluetooth video, audio plays 1 or 2 seconds later than the video. It's awful looking at a song video like that.
 

·
Registered
Joined
·
123 Posts
That delay between video/sound over Bluetooth is a pretty common issue. Addressing it is dependent on the hardware/firmware/software on both ends (car and phone); since the hardware in the car isn't going to change and the firmware/software is pretty unlikely to change, you're not going to see this get addressed.

But, if you use USB you shouldn't have that problem - I've never tried that, but I'd expect it to be in-sync. I also wouldn't be that surprised if the issue was still present, though - Infiniti hasn't a great job with this part of the technology (at least in the QX30).
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
USB still sucks...

That delay between video/sound over Bluetooth is a pretty common issue. Addressing it is dependent on the hardware/firmware/software on both ends (car and phone); since the hardware in the car isn't going to change and the firmware/software is pretty unlikely to change, you're not going to see this get addressed.

But, if you use USB you shouldn't have that problem - I've never tried that, but I'd expect it to be in-sync. I also wouldn't be that surprised if the issue was still present, though - Infiniti hasn't a great job with this part of the technology (at least in the QX30).
I thought exactly the way you think about the USB connection. So I recently received an iPhone 8 from my company, and decided to give a try both ways. Bluetooth has a delay, and even using the usb "iPod" connection it happens. By the way, I can charge and use the iPhone in bluetooth mode at the same time. If it is wired, even voice notes pklay through the iPod media... Big deception with Infiniti, the should've used the MB entertainment system...
 
1 - 5 of 5 Posts
Top