Infiniti QX30 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
My 2017 QX30 Premium has been terriffic for the year that I have owned it. But this morning a bunch of warnings lit up on the dash - "ABS unavailable", "Parking Brake", and the ever-annoying engine warning light. I have red a few comments about the secondary battery causing this kind of issue - could that be the case here? Thanks for any advice or texture...I am going to contact the local Infiniti dealer but is there anything I can do to better understand what's going on?
 

·
Registered
Joined
·
6 Posts
My 2017 QX30 Premium has been terriffic for the year that I have owned it. But this morning a bunch of warnings lit up on the dash - "ABS unavailable", "Parking Brake", and the ever-annoying engine warning light. I have red a few comments about the secondary battery causing this kind of issue - could that be the case here? Thanks for any advice or texture...I am going to contact the local Infiniti dealer but is there anything I can do to better understand what's going on?
I just had this same issue and when I read the codes I got a faulty left front abs wheel speed sensor as well as a trasmission code U1409 which lead to the wheel speed sensor, I ended up having alot of trouble as my car kept telling me that reverse was unavailable and not to shift gears. I ended up buying a new abs sensor from mercedes for only 20 dollars and fixed the problem so best thing I would say is read the codes and try to figure out what it is, if its the same problem I had itll only cost you 20 bucks and some elbow grease.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Thanks - the car drives, accelerates, brakes just fine...even the parking brake works! But I will shortly have the codes read and probably let the shop take care of any actual installation.
 

·
Registered
Joined
·
19 Posts
I've got the exact same car, and my battery gave out like two weeks ago. The dealership told me there were a ton of codes, and at the time, they weren't exactly sure what the source of the issue was. Once they replaced the two batteries, everything was peachy.
 
1 - 7 of 7 Posts
Top