Infiniti QX30 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
Hello guys,
Well guys bad news for my car....... I was having troubles with my battery not keeping charge, having issues in the morning and once the car turned on then it wouldn't shift gears actually the lights on the gear selector wouldn't lit and when tried to switch gears it would not do anything, would not allow me to deactivate the emergency brake and the main screen kept on cycling between cameras/gps/sensors.....
the screen on the dash said: 4 WD not available.
Took it to the dealer they had it for 2 days then replaced the battery... all good for 2 days, then yesterday, was turning on no problems but after a few minutes of driving got on limp mode.... check engine light on, message on the screen 4 WD not available again.... switching gear rough..... this afternoon tried to turn it on and seemed like battery was dead again
Will be going on Monday to dealer
any thoughts? someone having same problems?
 

·
Registered
Joined
·
107 Posts
I had the same problem too. Car was just dead one morning with the "4WD not available" displayed on dash. Had to jump it, took about 30 minutes. Check engine light stayed on for a drive cycle. That was about 3 weeks ago. Took it to dealership last week for diagnosis, and obviously they couldn't pull any codes and found nothing wrong.

I suspect this will be the next service bulletin... (after the one they did for crooked steering alignment).
 

·
Registered
Joined
·
62 Posts
Discussion Starter #3
I'm back from the dealer and of course no codes stored in the system...... but I think I got some "good" news for now, I am not the only one having this trouble and there is another car in Toronto that had same issues and now is in the dealer and some infiniti engineers are studying the case and as Smittylit said most probably will be a service bulletin coming up. Now if you guys have this issue do not disregard it if it goes away..... we all need to report any minor issue to infiniti so they understand what is going on and find a solution, I would hate that when the warranty expires all the "small issues" start to add up to something expensive.
Keep us posted if you have the problem and report it.
(now I am not aware of the steering alignment problem........ )
 

·
Registered
Joined
·
43 Posts
Thanks for the heads up! Sounds like something is draining the batter quickly, but this is just an assumption from me. Perhaps a recall in the future is in order.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #5
Update..... after a week at the dealer and them consulting with the tech line, they disconected, check and reconnected the harness that goes to the gear selector and the controls on the middle console (arm rest). Put it all back together and tried it, now the car is working fine, no error messages, no check engine light or codes.
It seems it was only a loose connection.......
 
1 - 6 of 6 Posts
Top