Infiniti QX30 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have been experiencing an issue when driving my 2017 QX30, I'll be stopped and my car will go into eco mode and when I take my foot off the break to drive again I'll hear a pop sound and my radio will turn off and right back on again. It's as though the eco mode is causing an electrical short? This doesn't happen every time but often enough for me to be concerned. I've also experienced another issue when my car is in eco mode, when I'm stopped and take my foot off the break the car will go automatically into neutral/limp mode, the dashboard will turn red and tell me to visit the dealer. I then put my car in park and back in drive and it goes back to normal. Anyone else experience this issue or know what might be occurring?

I took my car into the dealer last week just for its regular maintenance and mentioned these issues occurring every now and then. They tested my battery and said everything looked fine but it felt like they were just trying to get me out of there.

Any insight would be helpful, thanks!
 

·
Registered
Joined
·
69 Posts
Mine just did the same exact things. My car turned off at the light like yours with all the warning lights for the first time too....but it only happens when its auto stop/starting which i rarely use cuz i dont wear my seatbelt. Everyone has been saying it is due to the Auxiliary battery. Everyone also says its a very common issue and just get a new aux battery.
 
1 - 2 of 2 Posts
Top