QX30 - Squeaking Sounds from Steering Wheel When Turning at Low Speeds - Infiniti QX30 Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 04-20-2018, 09:10 PM Thread Starter
Junior Member
 
Otis's Avatar
 
Join Date: Apr 2018
Location: Mountain House, California
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default QX30 - Squeaking Sounds from Steering Wheel When Turning at Low Speeds

Hi,

I bought a 2018 QX30 three weeks ago. It has less than 1,000 miles on it. When leaving work the other day I noticed a low pitched squeaking noise when driving at a low speed and turning my steering wheel. I am able to recreate this problem at low speeds when turning the wheel.

A quick internet search didn't yield much. However, an old post from 2005 for an Infiniti M35x with a similar problem, required the owner to replace the power steering assembly to correct the noise on turning at low speeds.

I will be taking this into the dealer to look but was wondering if anyone has experienced this problem, and if yes, what was done to fix it?
Otis is offline  
post #2 of 8 (permalink) Old 04-21-2018, 12:36 PM
Senior Member
 
p07r0457's Avatar
 
Join Date: Oct 2017
Posts: 319
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Garage
Default

The QX30 has electric steering — so no pump to go bad/replace. I don’t think any of the M35 information would be useful.

You’ll probably need to let the dealer address it. Perhaps a misalignment between parts?

2018 Infiniti QX30 Premium AWD - Majestic White
2019 Volvo XC60 T6 AWD Inscription - Onyx Black Metallic
2018 Honda Gold Wing Tour - Pearl White
p07r0457 is online now  
post #3 of 8 (permalink) Old 04-26-2018, 03:11 PM
Junior Member
 
Join Date: Jan 2018
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Default

Sounds to me like something isn't set right, but I wouldn't imagine it being anything serious. Could just be some pieces that are coming into contact with one another. Have you had a chance to have it looked at yet?
Locke is offline  
 
post #4 of 8 (permalink) Old 04-27-2018, 01:58 PM
Member
 
Join Date: Jul 2016
Posts: 43
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Default

Maybe something in the steering column is making the sound. Think this happened in an older car of mine and it was more pronounced when the weather was cold.
LongRoad is offline  
post #5 of 8 (permalink) Old 05-04-2018, 12:20 AM
Junior Member
 
Join Date: Jan 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Press the "glass" (ok, acrylic) from the dashboard. That was in my case. Maybe it's the same in yours.
mudito is offline  
post #6 of 8 (permalink) Old 06-07-2018, 02:59 PM
Junior Member
 
Join Date: Jan 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Quote:
Originally Posted by mudito View Post
Press the "glass" (ok, acrylic) from the dashboard. That was in my case. Maybe it's the same in yours.
Took it to the dealer, they disassemble the cluster and tightened up everything and added a rubber seal, that did the trick. No squeeki noise anymore.
mudito is offline  
post #7 of 8 (permalink) Old 07-03-2018, 01:28 PM
tt6
Member
 
Join Date: Mar 2017
Posts: 82
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Default

Did you ever get this resolved? It's not something silly like the tires squeaking on a polished cement driveway or something?
tt6 is offline  
post #8 of 8 (permalink) Old 07-03-2018, 10:23 PM
Member
 
Join Date: May 2018
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Default

I had this issue on my Q50S. Even though it is a known issue, they didn’t fix it. Not that big of a deal so never went back.
MENTaL Dad is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome