Infiniti QX30 Forum

Infiniti QX30 Forum (https://www.infinitiqx30.org/forum/)
-   Engine and Technical Discussion (https://www.infinitiqx30.org/forum/engine-technical-discussion/)
-   -   QX30 - Squeaking Sounds from Steering Wheel When Turning at Low Speeds (https://www.infinitiqx30.org/forum/engine-technical-discussion/25770-qx30-squeaking-sounds-steering-wheel-when-turning-low-speeds.html)

Otis 04-20-2018 09:10 PM

QX30 - Squeaking Sounds from Steering Wheel When Turning at Low Speeds
 
Hi,

I bought a 2018 QX30 three weeks ago. It has less than 1,000 miles on it. When leaving work the other day I noticed a low pitched squeaking noise when driving at a low speed and turning my steering wheel. I am able to recreate this problem at low speeds when turning the wheel.

A quick internet search didn't yield much. However, an old post from 2005 for an Infiniti M35x with a similar problem, required the owner to replace the power steering assembly to correct the noise on turning at low speeds.

I will be taking this into the dealer to look but was wondering if anyone has experienced this problem, and if yes, what was done to fix it?

p07r0457 04-21-2018 12:36 PM

The QX30 has electric steering — so no pump to go bad/replace. I don’t think any of the M35 information would be useful.

You’ll probably need to let the dealer address it. Perhaps a misalignment between parts?

Locke 04-26-2018 03:11 PM

Sounds to me like something isn't set right, but I wouldn't imagine it being anything serious. Could just be some pieces that are coming into contact with one another. Have you had a chance to have it looked at yet?

LongRoad 04-27-2018 01:58 PM

Maybe something in the steering column is making the sound. Think this happened in an older car of mine and it was more pronounced when the weather was cold.

mudito 05-04-2018 12:20 AM

Press the "glass" (ok, acrylic) from the dashboard. That was in my case. Maybe it's the same in yours.

mudito 06-07-2018 02:59 PM

Quote:

Originally Posted by mudito (Post 50266)
Press the "glass" (ok, acrylic) from the dashboard. That was in my case. Maybe it's the same in yours.

Took it to the dealer, they disassemble the cluster and tightened up everything and added a rubber seal, that did the trick. No squeeki noise anymore.

tt6 07-03-2018 01:28 PM

Did you ever get this resolved? It's not something silly like the tires squeaking on a polished cement driveway or something?

MENTaL Dad 07-03-2018 10:23 PM

I had this issue on my Q50S. Even though it is a known issue, they didn’t fix it. Not that big of a deal so never went back.


All times are GMT -4. The time now is 11:52 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome